Welcome to the E90Fanatics forums. E90Fanatics is the premiere website for the next generation BMW 3 series with interactive forums, photo galleries, and technical information for BMW enthusiasts. If you are looking to talk about your E90 Sedan, E91 Touring, E92 Coupe or E93 Cabrio -- E90Fanatics is the place for you!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E90Fanatics > BMW E90 Forums > E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio - General Forum

E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio - General Forum
The E9X is the latest evolution of the BMW 3 series including the highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! Post questions about "upgrading" from your current E46 here or jump over to E90Fanatics.com!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 01-26-2010, 10:40 AM   #1
streetsweeper92
Registered User
 
Join Date: Jan 2010
Location: Nebraska
Posts: 2
My Ride: 2010 BMW 328i xDrive
328i xDrive 2010 factory amp

Ok, so I have a 2010 BMW 328i xDrive with the standard audio package. I ordered the BSW subwoofer kit and can not find the factory amplifier that I'm suppose to tap into with the line output converter. So pretty I need to find another solution or get some help. I have all of my trunk liners out and I promise you that there is no factory amp. I went onto some other blogs and there is a rumor going that BMW decided to go without amps in the new vehicles.

Somebody help me please. Thanks.
streetsweeper92 is offline   Reply With Quote
Old 01-28-2010, 07:49 AM   #2
kchow101
Registered User
 
Join Date: Jan 2010
Posts: 8
Hello there! I have a NEW 2010 328i. I am having problems with a scratching noise when I put the radio to loud. Bmw says its normal due to the fact that they REMOVED the amp and all the power is coming from the radio (it does not have enough power).

Are you having the same problem? If not put the bass and treble up and use a usb or ipod and turn it up! Also turn down your front speakers and listen to your rear ones (they sound like crap). If so contact bmw north america! I have a case with them and so do others. Let me know if you found a way to connect a aftermarket amp to the stcok radio.
kchow101 is offline   Reply With Quote
Old 01-28-2010, 09:57 AM   #3
kchow101
Registered User
 
Join Date: Jan 2010
Posts: 8
This is the letter I sent to the VP of BMW Marketing.

Jack Pitney
V.P. Marketing
BMW North America
300 Chestnut Ridge Road
Woodcliff Lake, NJ 07677

Dear Jack Pitney:
This letter is to complain about the radio problems I am having with my new 2010 Bmw 328i. I purchased it from Braman Bmw in Miami. 3 days after the purchase I noticed I could not turn up the radio; it would start making a crazy scratching noise.

I took it in to service that week. They had to order me a new radio, so I had to come back in another two weeks (the radio was in back order). The radio finally came in. They swapped the radios, the same problem was occurring. An engineer came out; he said “it was normal, that Bmw changed the radio system on the 2010s”. They removed the separate amp, and all the power was coming from the radio. Basically the cheap radio you guys put in does not have enough power.

They told me to contact Bmw North America. I did, I put in a claim. The
person in charge of my claim told me she would call me back that she had to speak to the service advisor supervisor from Braman. No call back happened. I tried calling her but no luck. So finally I spoke to a supervisor from Bmw NA, she called back that night. She said the fix would happen in late Jan. Nothing. I called her, she now said late spring, that she has no other info for me.

I am driving in brand new Bmw, a $40,000 car. A Nissan Versa (the cheapest car in North America) has a better sound system (actually one that works) than this car. I expected a much higher level of quality from your company, and I am quite disappointed. This is my second 328i; we are also on our second Mini Cooper. All purchased from Braman (that’s a total of four cars from Bmw). These two cars will be our last!
kchow101 is offline   Reply With Quote
Old 01-29-2010, 11:28 AM   #4
streetsweeper92
Registered User
 
Join Date: Jan 2010
Location: Nebraska
Posts: 2
My Ride: 2010 BMW 328i xDrive
Well written letter. I kind of gave up on the speaker set up since removing the factory amp does make replacing the audio system a little bit easier. I just wrote a not on the factory survey that they sent me about partnering with an audio company that could really help them make these the "ultimate driving machine." They are going to lose a lot of customers since this is becoming a very common problem. I may just gut the entire system and add a double din flip of nav/dvd/mp3 cd player/iPod adapter and then run a set of Focal K2's in the 4 interior speakers place with a custom enclosure either from BSW or have something made to fit behind the wheel well in the trunk. I'll let you know what I decide. Hopefully if BMW replies to your letter they can get you taken care of.
streetsweeper92 is offline   Reply With Quote
Old 02-23-2010, 09:24 PM   #5
carln
Registered User
 
Join Date: Feb 2010
Posts: 2
Overall, I love my new brand new 2010 328i sedan with M Sport, Premium, and 6 speed stick. However, driving to work I noticed that speaker popping too! Not what I expect from a $41K car! My brother's 2007 328i with the standard audio system is way better. Now, I've read that the two subs were deleted, but this is not true. I thought those front door 4 in speakers were putting out way too much base. So, I looked under the front seats and sure enough, there is a small sub under each front seat. However, I am missing the sail panel tweeters and the rear speakers sound like absolute crap. I'm still writing a letter and will also investigate some BSW speakers.
carln is offline   Reply With Quote
Old 03-18-2010, 08:27 AM   #6
kchow101
Registered User
 
Join Date: Jan 2010
Posts: 8
yeap fellas!!! bmw just got cheap on their radios! SEND THEM LETTERS!!!!!!!!!! COMPLAIN!!!!!!!! they are suppose to put me in a 2011 bmw with the logic 7 system! it is in order!
kchow101 is offline   Reply With Quote
Old 03-19-2010, 08:10 AM   #7
John1225_e90
Registered User
 
Join Date: Mar 2010
Posts: 22
Keep sending them....I just sent a few out myself. BMW customer service is a joke. My case manager is the biggest tool. Couldn't find my complaint because they put in the wrong VIN, etc.

Thanks for the contact on the VP. Customer service wouldn't give me any contact information. Tool told me he was it.......
John1225_e90 is offline   Reply With Quote
Old 04-28-2010, 05:41 AM   #8
Dexter1
Registered User
 
Join Date: Apr 2010
Posts: 8
What you mean the are going to put you in a 2011 with the prologyc system, just like that, I just got my 2010 in march and had a 2007 that the sound system was good, but the 2010 really socks I got mine from Valencia BMW and next week they will replace the usb connector for the ipod interphace because in my case it seems like the sound distortion occures only when I use my iphone or iphode CD and radio does not sound so bad but yeah I would love to have a better sound system for the kind of vehicle we are driving is a shame that cheaper cars have better quality systems. so how is it that you are getting the 2011 is it because of the audio system or you just ordering it for the first time. and who did you talk to in BMW.
Dexter1 is offline   Reply With Quote
Old 04-28-2010, 11:54 AM   #9
kchow101
Registered User
 
Join Date: Jan 2010
Posts: 8
i am still waiting! the dealer told me they were getting things inorder. also it takes month and a hlaf to order and receive car. keep harrassing bmw north america. thats what i did. contact presidents, vice presidets, and their mothers!! lol!!
kchow101 is offline   Reply With Quote
Old 06-01-2010, 11:22 PM   #10
carmel58
Registered User
 
Join Date: Jun 2010
Posts: 6
Quote:
Originally Posted by carln View Post
overall, i love my new brand new 2010 328i sedan with m sport, premium, and 6 speed stick. However, driving to work i noticed that speaker popping too! Not what i expect from a $41k car! My brother's 2007 328i with the standard audio system is way better. Now, i've read that the two subs were deleted, but this is not true. I thought those front door 4 in speakers were putting out way too much base. So, i looked under the front seats and sure enough, there is a small sub under each front seat. However, i am missing the sail panel tweeters and the rear speakers sound like absolute crap. I'm still writing a letter and will also investigate some bsw speakers.
i bought the same car and my front speakers a popping also a low crackling noise when the base is higher 3-10 mode i went back to the dealer and they claim to have replaced all of the audio, front dr speakers, amp and recvr/radio and it still makes this crackling noise hissing shorting out noise. I complained to bmw of north america and they are going to look into it for me?
carmel58 is offline   Reply With Quote
Old 06-01-2010, 11:27 PM   #11
carmel58
Registered User
 
Join Date: Jun 2010
Posts: 6
Quote:
Originally Posted by kchow101 View Post
Hello there! I have a NEW 2010 328i. I am having problems with a scratching noise when I put the radio to loud. Bmw says its normal due to the fact that they REMOVED the amp and all the power is coming from the radio (it does not have enough power).

Are you having the same problem? If not put the bass and treble up and use a usb or ipod and turn it up! Also turn down your front speakers and listen to your rear ones (they sound like crap). If so contact bmw north america! I have a case with them and so do others. Let me know if you found a way to connect a aftermarket amp to the stcok radio.
I HAVE THE SAME PROBLEM WITH MY NEW 2010 328I SDN MSPORT THE SAME CRACKLING, POPPING SHORTING OUT NOISE WHEN I PLAY UP THE BASS BETWEEN THE MODES 3 THRU 10. THE DEALERS CLAIM THEY GOT THE GET GO TO REPLACE THE RADIO/RECVR, FRONT DR SPEAKERS AND AMP FROM BMW AND IT STILL THE SAME MAKING THE NOISE BUT LESS ONLY WHEN CERTAIN CD'S ARE PLAYED LIKE J JACKSON'S "ALL FOR YOU" IS PLAYING ON THE CD? PLEASE INFORM ME IF YOU HAD ANY ANSWERS TO WHY IT IS STILL DOING THIS IF THE AUDIO HAS BEEN REPLACED? THANK YOU...
carmel58 is offline   Reply With Quote
Old 06-01-2010, 11:34 PM   #12
carmel58
Registered User
 
Join Date: Jun 2010
Posts: 6
Quote:
Originally Posted by kchow101 View Post
This is the letter I sent to the VP of BMW Marketing.

Jack Pitney
V.P. Marketing
BMW North America
300 Chestnut Ridge Road
Woodcliff Lake, NJ 07677

Dear Jack Pitney:
This letter is to complain about the radio problems I am having with my new 2010 Bmw 328i. I purchased it from Braman Bmw in Miami. 3 days after the purchase I noticed I could not turn up the radio; it would start making a crazy scratching noise.

I took it in to service that week. They had to order me a new radio, so I had to come back in another two weeks (the radio was in back order). The radio finally came in. They swapped the radios, the same problem was occurring. An engineer came out; he said “it was normal, that Bmw changed the radio system on the 2010s”. They removed the separate amp, and all the power was coming from the radio. Basically the cheap radio you guys put in does not have enough power.

They told me to contact Bmw North America. I did, I put in a claim. The
person in charge of my claim told me she would call me back that she had to speak to the service advisor supervisor from Braman. No call back happened. I tried calling her but no luck. So finally I spoke to a supervisor from Bmw NA, she called back that night. She said the fix would happen in late Jan. Nothing. I called her, she now said late spring, that she has no other info for me.

I am driving in brand new Bmw, a $40,000 car. A Nissan Versa (the cheapest car in North America) has a better sound system (actually one that works) than this car. I expected a much higher level of quality from your company, and I am quite disappointed. This is my second 328i; we are also on our second Mini Cooper. All purchased from Braman (that’s a total of four cars from Bmw). These two cars will be our last!
DID YOU EVER GET ANSWER YET? IF YOU DID PLEASE INFORM ME ON WHO YOU SPOKE TO AND HOW I CAN GET IN TOUCH WITH THEM ALSO. I JUST PUT IN A COMPLAINT ABOUT THE DEALER WHO DIDNT FIX MY SAME PROBLEM. I GUESS THIS PROBLEM IS UNIVERSAL AND THERE ARE OTHERS OUT THERE WITH THE SAME PROBLEM AS MINE? HERE'S MY EMAIL SO YOU CAN GET IN TOUCH WITH ME: carmel19582000@yahoo.com
PLEASE ADVISE IF YOU RECV SOME ANSWERS. I TOO ARE DRIVING AROUND IN A NICE 45,000 CAR AND IT SHOULD HAVE A FLAWLESS RADIO INSIDE IT NOT A CHEAP RADIO MY OTHER 2007 328I COUPE HAD A BETTER RADIO THAN THIS? THANKS FOR YOUR TIME AND EFFORT.
EPS
carmel58 is offline   Reply With Quote
Old 06-03-2010, 05:57 AM   #13
Hoosier_e90
Registered User
 
Join Date: Jun 2004
Posts: 116
I just got a new 335cic. Sticker on the car was just over $59,000. I am seriously disappointed in the stereo system. I've had 3 previous BMW and the stereos have been great, but this one just sounds flat. Sound comes at you directly from the speaker in the door, my other BMW the sound just surrounded you, clear and loud.

very disappointing, not sure what can be done to remedy it.

Also, since I'm at it. I picked up my car last week, no floor mats!?!?! I asked where the floor mats were and they said BMW quit including floor mats quite a while ago. I've never had to buy floor mats. Come on, $59,000 and no floor mats?

Lastly, I got an auto for the first time. Pretty disappointed in that too. Car performs OK while in sport, but regular setting feels just plain sluggish. I've had 3 3 series sedans, all with manual transmission. Those cars drove like sports cars. This one just feels soft was far as acceleration and response. In fact, my wife's Audi Q5 seems to have better throttle response. My mileage has sucked too.

I do love driving with the top down though.

OK, next time, M3 sedan with a manual transmission, I know that won't dissapoint.
Hoosier_e90 is offline   Reply With Quote
Old 06-04-2010, 04:04 PM   #14
railroader
Registered User
 
Join Date: May 2009
Posts: 7
Hoosier^^ isn't your new car the twin turbo motor? I'm surprised it feels sluggish- it's supposed to have a
faster 0-60 than my car, the 335d. My diesel is FAST-- big torque; however, the car before that was a 08
328i standard- now that car felt sluggish, except in DS mode. I was also a die hard manual guy and I feel the
335d has a satisfactory tranny for my first automatic in my life (and I'm 58!) Toggles work great going up or down!

Quick comment on factory sound systems (original theme of the thread.) My 328i standard had mediocre sound
and also exhibited the distortion the other posters spoke of. But my new car had Logic7 and is good, strong and
distortion free at even the louder settings. Does Logic 7 include a separate factory amp, guys? And where is it located?
My only minor, minor quibble is the HD radio sometimes cuts in and out if the signal is weak; but I guess you can't blame
the car for where you are in a weak AM/FM sig zone...all in all, I've very happy with the 335d; rock on!
Thanks guys...

My car came with the monogrammed floor mats! (2010 335d bought in March this year.) What's the deal about
not giving them to you?? You've got the convertible, right? I think you should have received mats- I'd call the
District ppl and follow up on this! Good luck, bro'!
railroader is offline   Reply With Quote
Old 09-05-2010, 10:58 AM   #15
cjk26md
Registered User
 
Join Date: Sep 2010
Posts: 2
Hey guys, I have a 2010 BMW 328i, and have taken it in about 4 times now, for speakers clicking, popping, and making several other annoying noises. Each time they assure me they fixed it. First it was a cable in the door, then the speaker in the door was blown, then the insulation in the door, now they have to replace the "sub woofer" after replicating the issue on a test drive with a tech. My question is, Do I even have a sub woofer in the '10 model without logic7? I have trouble trusting this dealership as one of of the times my vehicle went in, they marked on the paper all my fluids were filled and everything checked, along with the speaker being fixed..windshield wiper fluid was still empty, and speaker still made noise.and I have IDrive so as soon as you get in the car it pops right up and annoys you its empty! This is my first BMW and I bought it in December. Im getting very frustrated.

Thank you,
Chris
cjk26md is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -5. The time now is 10:32 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use