Welcome to the E90Fanatics forums. E90Fanatics is the premiere website for the next generation BMW 3 series with interactive forums, photo galleries, and technical information for BMW enthusiasts. If you are looking to talk about your E90 Sedan, E91 Touring, E92 Coupe or E93 Cabrio -- E90Fanatics is the place for you!

You are currently viewing our boards as a guest which gives you limited access to view most discussions and access our other features. By joining our free community you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is fast, simple and absolutely free so please, join our community today!

If you have any problems with the registration process or your account login, please contact contact us.

Go Back   E90Fanatics > BMW E90 Forums > E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio - General Forum

E90 Sedan / E91 Wagon / E92 Coupe / E93 Cabrio - General Forum
The E9X is the latest evolution of the BMW 3 series including the highly tuned twin turbo 335i variant pushing out 300hp and 300 ft. lbs. of torque. BMW continues to show that it sets the bar for true driving performance! Post questions about "upgrading" from your current E46 here or jump over to E90Fanatics.com!

Reply
 
Thread Tools Search this Thread Rate Thread Display Modes
Old 06-03-2014, 06:52 PM   #1
Rahsblk330i
Registered User
 
Join Date: Mar 2013
Location: Conneticut
Posts: 95
My Ride: 328i
My e90 stock radio is loosing its mind!

Yesterday I was driving and my audio shut off! The power to the radio stayed on but the audio in the aux mode cd and radio mode would not output audio. Then while driving it randomly came back on then today it was off and on. Anyone know why it's doing that? I never had problems with it b4.
Rahsblk330i is offline   Reply With Quote
Old 06-03-2014, 08:29 PM   #2
atinybug
Registered User
 
Join Date: Apr 2004
Location: Atlanta
Posts: 373
My Ride: e92 335i
Check fuses and connections, sounds like something might be loose.
atinybug is offline   Reply With Quote
Old 07-15-2014, 10:00 PM   #3
mdep
Registered User
 
Join Date: Jul 2014
Posts: 1
Check and see if anything spilled in your trunk and check your amp under the trunk floor panel towards the back of your trunk near back seats. I had a taillight leak and same symptoms as you.,,,, had to replace amp


Sent from BimmerApp mobile app
mdep is offline   Reply With Quote
Old 07-16-2014, 07:31 AM   #4
Rahsblk330i
Registered User
 
Join Date: Mar 2013
Location: Conneticut
Posts: 95
My Ride: 328i
Thanks I figured it may be the amp
__________________
E90BAI!
Rahsblk330i is offline   Reply With Quote
Reply

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On



All times are GMT -5. The time now is 08:17 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.
(c) 1999 - 2011 performanceIX Inc - privacy policy - terms of use